Skyhound Forums

Full Version: "Enter Coordinates" tab missing in Search
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Greg,

I noticed the "Enter Coordinates" tab of the Designation Search is not there although the help shows it (see attached a capture with both dialog windows). Is there any way I can search for objects located at a given RA/Dec location? Or to display the interactive atlas centered at that location (I understand there may be no object there so the target-oriented workflow would not be applicable). This is with 4.0d.

Thank you,


That's an error in the help page. After I added the screen capture for the help I realized that the Enter Coordinates tab doesn't make sense for adding objects to target lists, since you can't add simple coordinates to a list. So I removed it, but forgot about the screen capture.

FYI the top part of that dialog appears when you select a target for a chart, which is when the enter coordinates tab makes sense.

BTW if you wish to enter coordinates for some reason, create a Skymark instead. This is most easily done via a right-click on a chart. A Skymark works similarly to a catalog object, but consists of only coordinates.
Thanks for the quick reply, Greg. It's a minor thing but would be nice to be able to go to a location identified by coordinates without creating a skymark. Why? Because I may want to check a particular area of the sky whose coordinates I know from elsewhere and because the data in the ST4 catalog has been curated. 

This is what I tried:

  1. search for an arbitrary or select one in an existing list
  2. display the interactive atlas
  3. right-click, Create skymark at cursor
  4. enter the RA/Dec that I actually want, click ok. The skymark is created but the map doesn't move to it (understandably, since I opened it for the arbitrary object chosen at step 1)
Then I tried to show the interactive atlas for the skymark. 
  • click on the Data menu, then Skymarks - I can see them but from a skymark I cannot navigate to the atlas. 
  • I tried searching for the skymark in the Designation search. It didn't appear. I clicked around then minutes later when I tried again, the skymark appeared in the results (I performed the same search). To test I created a third skymark, then searched for it by designation (no results), then clicked around, double-checked it was shown in Data/Skymarks, then tried again in Designation search but still nothing. And then several minutes later (I was typing this email in the meantime), an identical search shown the third skymark. Hmm... is there an indexing delay?
So two things:
  • while feasible, getting from coordinates to display the interactive atlas required a number of steps. It'd be great if there's a quicker way (such as if "Enter Coordinates" comes back, perhaps?). Or have an "Open Atlas" option under Tools (there already is another option for charts, "Open Last Chart" so perhaps have a "Chart" menu with two options, "Open Last" and "Enter Coordinates")?
  • when you have a moment, can you please try to reproduce the issue with the delay in searching by skymark? Let me know if I can help with anything.
Thanks again.

I think you are making it much more difficult than it needs to be. As I said, the Skymarks are only necessary if you want to add coordinates to a target list (or if you want to be able to refer to them permanently). All you need to do is open the atlas and click in the upper left (where the target is located). You can enter coordinates directly there. They never left.

A couple of other things:

1. Edit the Skymark data via the database. It isn't meant to be used in any other way, nor would that be desirable.

2. I don't know why there would be a delay. Once the Skymark is added to the database it should be immediately searchable. The process is very straight forward. Are you possibly sharing your databases via OneDrive or something? I;ll try it and see, but I have not seen a delay in the past.

3. Skymarks are also browsable via the Browse tab of the Designation Search Tool (Select Skymarks as the database to browse).
Hi Greg,

I didn't realize the Enter Coordinates tab was still accessible via that path. OK, that solves it and avoids the need to deal with skymarks, which are more permanent than I needed in this use case.

For the delay I don't have an explanation. The database is local (and the computer is an i7 bought a few months ago, SSD drive - not that it should make a difference here). I've just tried from my Thinkpad and the skymark appeared immediately in the search results. Weird but since it's not reproducible, you can ignore it.

Clear skies,

It may be that the delay is caused by a lazy write, where the data isn't flushed immediately to the actual file. But I doubt that's it. I'll keep thinking on it.
I've just tried to verify this hypothesis on the same computer and it's odd. I created a new skymark and it was immediately found in Designation Search. Then I created another, but this one did not appear in the results. I created one more, still not found.

I flushed all disk buffers with Sysinternals Sync, searched again. The last two were not there. I double-checked in Data/Skymarks, they were defined (also proven with a peek in SkyTools 4\UserPath\skymark.bin, I saw the name there).

I restarted ST4, searched again. The last two were not there. Some seconds later I searched once more, then all of them appeared.

I said ok, let's try once more. At 9:33pm today I created a new skymark and while searching, I monitored file accesses with ProcMon from Sysinternals. I can see skytools.exe reading successfully from skymark.bin, skymark_alpha.bin, skymark_pid.bin (as well as the other data files). Interestingly, while skymark.bin contained that latest skymark, skymark_alpha.bin did not, just the previous ones. I do not know the difference between the files but this discrepancy might be relevant if skymark_alpha.bin is used for searching (at least the file is read). I added then two more skymarks, but only skymark.bin was updated on the disk, skymark_alpha.bin was not, even after flushing.

You will know better if the above is relevant. I'll continue digging.

EDIT: Found something! When I add a skymark, skymark.bin is updated with it and skymark_alpha.bin appears (without it). And the searches do not find the new one. If I go in Data/Skymarks, delete a skymark (not the last one but an older one), then skymark_alpha.bin disappears and the search is successful. I did it twice in the row, it was reproducible. And then I did one more test: instead of deleting a skymark, I simply deleted skymark_alpha.bin from the disk (while ST4 was running, kind of impolite, I know). And the search was successful! So somehow, the presence of the file or the fact that it appears to have older content, is clearly related to the problem. I hope this is enough information for you to identify the cause.

Other than not being updated, what you have described is normal. The skymark_alpha.bin file should be updated when you add a new skymark. I can't think of a reason why it might be updated sometimes and not others. I'll have a look at the code. Maybe there is something amiss.