Skyhound Forums
Crash when Clicking Exposure Goals and Filters - Printable Version

+- Skyhound Forums (https://skyhound.com/forums)
+-- Forum: SkyTools Support (https://skyhound.com/forums/forumdisplay.php?fid=20)
+--- Forum: SkyTools 4 Support (https://skyhound.com/forums/forumdisplay.php?fid=46)
+--- Thread: Crash when Clicking Exposure Goals and Filters (/showthread.php?tid=392)



Crash when Clicking Exposure Goals and Filters - Rowland - 2018-11-23

Somehow I managed to define two projects for the Pleiades, both using the same imaging system.

The projects had different names - one was Pleiades 120-OSC, the other just Pleiades.

When I clicked the white P/blue square icon next to Pleiades in the Target list, it brought up the project manager showing the two different projects.

I clicked the one named Pleiades and then clicked the Delete button, which removed it from the list of projects.  

Now when I click the Project icon for the Pleiades in the target list, it opens the Edit Imaging Project dialog for Pleiades 120-OSC as expected.

When I click Exposure Goals and Filters, there is a brief delay, then ST4 crashes to the desktop.

I'm not sure if this is related to the "two projects and then I deleted one" scenario, but seems likely so I'm including that info.

Cheers,
Rowland


RE: Crash when Clicking Exposure Goals and Filters - theskyhound - 2018-11-26

Hi Rowland,

It is allowed to have more than one project, as long as they have unique names. I wonder if it is possible that somehow the project that crashes is referencing a filter that is no longer available. I have gone to lengths to keep this from happening, but it is the most likely cause of a crash on this tab. Try opening the imaging system and opening the filters assigned to it, and then closing the imaging system.


RE: Crash when Clicking Exposure Goals and Filters - Rowland - 2018-11-26

Hi Greg,

I opened the imaging system, selected each of the filters and clicked View/Edit, and then clicked Done and closed the imaging system.

I then opened the Pleiades project and clicked on the Exposure Goals and Filters tab, and ST4 crashed to the desktop.

I had two filters associated with this imaging system, which is an OSC camera. The filters are still defined, so I'm not sure if that's what's happening here.

Let me know if I can try any other experiments to help you troubleshoot this.

Cheers,
Rowland