Skyhound Forums
Scope Connection Problems - Printable Version

+- Skyhound Forums (
+-- Forum: SkyTools Support (
+--- Forum: SkyTools 4 Support (
+--- Thread: Scope Connection Problems (/showthread.php?tid=444)

Pages: 1 2

Scope Connection Problems - Nemesis@3319 - 2019-01-03

SkyTools 3 connects thru ASCOM's Generic Hub to my LX 200GPS (Com3) just fine. However, SkyTool 4 will not. It produces the following error, " SkyTools has stopped working disconnect or troubleshoot". Disconnecting simply shuts down SkyTool 4. Have tried SkyTools 4 thru ASCOM Generic Hub to ASCOM simulator and it connects. Have uninstalled SkyTools 4 and reloaded it but problem does not go away.

RE: Scope Connection Problems - theskyhound - 2019-01-03


Unfortunately this is a difficult thing to debug. Some things to consider:

1. I haven't had any similar reports.
2. The ASCOM client code has barely changed since V3

The error message appears to be coming from somewhere down the ASCOM chain rather than from SkyTools. It appears to be claiming that SkyTools has crashed, or is no longer talking to it. Is SkyTools still functioning when this error appears? The source of the error window will be displayed in the top of the error window. Does it say SkyTools or something else?

Please check that the ASCOM settings are identical in ST3 and ST4. You configure by clicking on the Telescope Control Menu and selecting Select / Configure Telescope --> ASCOM Supported Telescope. The ASCOM Chooser will appear. Select the Generic Hub and the Properties. All the settings should be identical to those being used by ST3.

When you select Choose Scope, also check the Scope properties. I suspect a setting here is not correct.

RE: Scope Connection Problems - Nemesis@3319 - 2019-01-04


Have uninstalled and reinstalled ASCOM/Scope drivers in hopes that I might have a bad set of files somewhere. Did nor make a difference - same problem still as before. I have attached a file showing the error I am getting. All my other programs work thru the ASCOM generic hub just fine. Will try contacting ASCOM folks and send the error I am getting. Hopefully they will know what's going on.

RE: Scope Connection Problems - theskyhound - 2019-01-05


This may be helpful, but in order to help further, please follow the steps I outlined in my previous message and report back. Here is what I suspect: the ASCOM settings are not stored for a given telescope, they are stored separately for each ASCOM client, E.g. SkyTools 3 and SkyTools 4. Only if you have carefully set everything up the same in ST4 as in ST3 can we assume things will work the same.


RE: Scope Connection Problems - Nemesis@3319 - 2019-01-05


Sorry, my fault did not report the results to your earlier post.

1) Top left hand corner of error window shows "SkyTools"

2) Yes, SkyTools 3 connects after SkyTools 4 crashes.

3) Checked Hub/scope properties they are identical.

4) I would like to try one last thing on my end here and do a clean download of ST4 to my observatory computer. The program I now have was a transfer of ST4 from my desktop computer. Perhaps the transfer was corrupted or confused by the way I put ST4 on the observatory computer. Would like to have a direct link from Skyhound to do that.

RE: Scope Connection Problems - theskyhound - 2019-01-05


How did you transfer ST4 from the other computer? Did you install it via the supplied installer?

Unfortunately, it would seem unlikely that a clean install would resolve this kind of problem. The integrity of the files are checked during the install, and if you only transferred your "user" files from the "SkyTools 4" folder in your documents, it is unlikely that an error in one of these files would cause this kind of problem. But go ahead anyway if you want to. Stranger things have happened. Keep in mind that a clean install requires that the "SkyTools 4" folder in your Documents be deleted after uninstalling but before re-installing.

From your error message I can discern that he error is arising in ASCOM and is only being displayed by SkyTools (which is designed to quit when a severe error occurs). If re-installing does not work, I suggest contacting the developer of ASCOM for support and sending them the error message. The problem could possibly be triggered by SkyTools, but I don't have access to the ASCOM code, or your mount, so I have no idea how or why. Keep in mind that the SkyTools end of these things is very simple. It just does things like, "start ASCOM" and ASCOM does the rest. There is a small window for problems in the calls that SkyTools makes right after things start up, but it does not appear that you are getting that far.

RE: Scope Connection Problems - Nemesis@3319 - 2019-01-06


OK, as you expected uninstalling ST4 and reinstalling did not help solve the problem. Tried systems mechanic to clean register and generally clean up OS, did not help. I give up, being a systems level type I am out of ideas. Oh well I still have SkyTools 3 will shelve 4 and use ST3. A shame really as ST4 had some features I wanted to use. Thanks for helping, appreciate your thoughts on this problem.

Himesa Obs

RE: Scope Connection Problems - theskyhound - 2019-01-06

Bob, please do not give up. This problem needs to be resolved, if not for you, then for the next person who runs into it.

Please contact the developers of the software that is generating the error message (ASCOM) and ask them about the message. Tell them what mount you use. This stuff is complicated. If they need to talk to me, please have them contact me.

RE: Scope Connection Problems - Nemesis@3319 - 2019-01-07


I have been in constant communication about this problem with ASCOM help and have tried their suggestions but nothing has helped to date.

RE: Scope Connection Problems - theskyhound - 2019-01-07

Hi Bob,

I didn't realize you had contacted ASCOM. I know this must be very frustrating. The error that is being reported is highly unusual and very basic. It appears that a module is failing to load. This gives us very little to go on. If I could make this happen myself, perhaps by connecting to the simulator, I could determine at what point the error is occurring, which might give is a clue.

One suggestion I can make is to consider your anti-virus software. Problems related to over-zealous anti-virus software have been increasing, and the kinds of problems that we run into keep getting more sophisticated. Some software is notorious for not telling the user what it is doing when it takes action. I find that the anti-virus that comes with windows works fine and has not caused any problems. If you are running another anti-virus, have a look at its logs, or even consider disabling it.

Have you considered using a different hub?

I will let you know if I find out anything about this issue.